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This is the student’s guide for following the Excel and Civic Data workshop.  It is modular, in that you can use each part independently.  It is meant to be used along with the Excel files in this accompanying folder, but can also be used with any other open government data.  It works best with data that includes location information, and some kind of date information (like an address and a completion date).  

For this tutorial, you should use Excel 2016 for Windows.  While most of this can be done in Excel 2013 for Windows, some of the menus and names have changed.  Many of the tools are specific to Excel for Windows, so if you have attendees using a Mac, they should still use the Excel Windows version using either Basecamp or Parallels.  
If you are using Excel 2013, you will want to download Power Query to access the functionality discussed in this tutorial.  You will need to download Power Map if you are using Excel 2013 to access the mapping functionality. Some of the new chart types are specific to Excel 2016.  It is not recommended for versions earlier than Excel 2013. 

The workshop is divided into the following sections:

· Accessing data
· Analyzing data
· Mapping data (Windows only)
· Transforming data
· Advanced analytics (an optional module)
Getting Stared
Excel is a tool that most people are familiar with, and many people use every day. Excel can be leveraged to unlock the value of open data of all kinds, and it is particularly well-suited to query and visualize open government data from multiple sources.  In this tutorial, you will learn how to access, transform, cleanse, query, and visualize data using tools that are easy to learn and easy to use.  
The scenario used here is Chicago's open data, and the files are located here: https://doc.co/smWQbx  
 
Accessing Data Sources in Excel 
 
Open City Data Portal - at http://data.cityofchicago.org
 Explore the interface of the data portal
Explore the categories and types of data (tables, maps, etc)
Click on Export and explore (and explain) the export options, and describe when to use what 
Explore that it contains both datasets and maps.  The maps can be downloaded and used later in the Mapping section
Open the Employee Salary dataset called the  Current Employee Names, Salaries, and Position Titles data set.
Open the Export field and scroll down to and open the oData box.
 
 
Now we are going to look at the data connection wizard for oData feeds
Select and copy the oData URL
On the Data Tab, note the buttons on the Get External Data section.
Click on the From Other Sources arrow and choose "From oData Data Feed"
Paste the URL into the Link or File box
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Data Connection Wizard 
Connect to a Data Feed 
Enter the information required to connect to a data feed. 
I. Location of the data feed 
Link or File: 
2. Log on credentials 
@ use the sign-in information for the person opening this file 
arm,vse... 
C) use this name and password 
user Name: 
Password: 
Cancel 
Back 
Next > ]
 
Click on Next 
Click on the only table there
Click Finish
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Import Data 
Select hcn,v you want to view this data in your workbook. 
@Table 
C) PivotTable Report 
C) PivotChart 
C) Power View Report 
C) Only Create Connection 
Where do you want to put the data? 
@ Existing worksheet: 
C) New worksheet 
Add this data to the Data Model 
Pcoperties... 
Cancel ]
 
Click OK

Web Data
Here we are going to take data from a Wikipedia page and connect the tables it contains into Excel automatically.

Explore the Wikipedia page: https://en.wikipedia.org/wiki/List_of_neighborhoods_in_Chicago
Click on the Data tab on the ribbon
Under the Get External Data section, click New Query and on from other sources
Choose From Web
For the URL, give it the same URL as the web page you opened (https://en.wikipedia.org/wiki/List_of_neighborhoods_in_Chicago)
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Choose the List of Neighborhoods…table and click on the Load button
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Click on the filter arrow next to Community Area
Start typing Lakeview
Note that eight neighborhoods show up
Clear the filter

Creating Pivot Tables
Click inside the table
Click Pivot Table from the Insert Tab (in the Tables section)
We will use the defaults, so choose OK

Drag Community Area to Rows, and Neighborhood below Community Area
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Analyzing Data
Try using the filters by filtering to a department - for example, filter just the Aviation department. 
Then clear the filter.
 
Take salary and format the entire column as $
You can use the Reduce the Decimal button so that it is only dollar values, no cents
 
In the empty column to the right of employee salary type a name first row - something like "New Salary"
 
In the first empty row (2) start typing "=" and then click on the column to the left. 
Note that in the formula bar, instead of a cryptic row and column, it gives you a meaningful name
Now type * 1.05 and hit enter.  
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=[@[employee_annual_salary]]*1.05 
job_titles 
WATER RATE TAKER 
POLICE OFFICER 
POLICE OFFICER 
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CIVIL ENGINEER IV 
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TRAFFIC CONTROL AIDE-HOURLY 
STAFF ASST TO THE ALDERMAN 
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WATER MGMNT 
POLICE 
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STREETS & SAN 
OEMC 
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Number 
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*1.05 
84,450 
84,450 
89,880 
106,836 
70,764 
41,850 
20,051 
49,452 ]
 
 
Hit enter
You should have "=[@[Employee Annual Salary]]*1.05" in the formula bar
Format as dollars by clicking $ on the toolbar.
 
Quick Analysis Tools

Click on a cell in the table
Ctl+Q to bring up the quick analysis tools
Hover over the data bars, the color scale, the icons
Choose Data Bars and note how they provide a visualization within the cell
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WATER RATE TAKER 
POLICE OFFICER 
POLICE OFFICER 
CHIEF CONTRACT EXPEDITER 
CIVIL ENGINEER IV 
ASST TO THE ALDERMAN 
GENERAL LABORER - DSS 
TRAFFIC CONTROL AIDE-HOURLY 
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ELECTRICAL MECHANIC 
FIRE ENGINEER-EMT 
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POLICE OFFICER 
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CLERK Ill 
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POLICE OFFICER 
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FIREFIGHTER/PARAMEDIC 
ENGINEERING TECHNICIAN VI 
FIREFIGHTER-EMT 
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-PARAMEDIC 
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TREE TRIMMER 
TRAFFIC SIGNAL REPAIRMAN 
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90,744 
84,450 
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89,880 
106,836 
70,764 
41,850 
20,051 
49,452 
93,600 
100,320 
90,618 
2,756 
46,896 
73,920 
74,028 
81,588 
99,228 
81,588 
88,596 
108,228 
92,682 
111,474 
17,846 
93,600 
58,536 
41,850 
2,756 
87,384 
70,380 
72,862 
25,334 
46,668 
106,836 
106,836 
98,616 
70,380 
59,652 
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95,281 
88,673 
88,673 
94,374 
112,178 
74,302 
43,942 
21,054 
51,925 
98,280 
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2,894 
49,241 
77,616 
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117,048 
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Charts 
Data Bars 
Color... 
112,178 
112,178 
103,547 
73,899 
62,635 
Totals 
Icon Set 
Tables 
Greater... 
Sparklines 
Clear... 
Conditional Formatting 
2,756 $ 
uses rules to highlight interesting data. 
2,894 ]
 

Click on a cell inside the table
Ctl+Q to bring up the quick analysis tools
Try Data Bars
Try icons
Sparklines

Open the Sparklines for Housing Centers workbook
	Click on the Insert tab on the ribbon
	Click on Line
	Select the range of numbers for the data range
[image: ]

	And the corresponding area in column G for the location range (in this one, it is G5:G17)
	Make the column with the sparklines wider


	In the Show section, check High Point and Low Point
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	Click on the Marker Color
	Choose a separate color for the High Point and the Low Point

	Change the numbers in row 5 (Bethel New Life in the example) to be single digit numbers like 1, 2, 3, 4,5.  
Click on the Design tab
Click on the arrow under Axis
Change both the Vertical Axis Minimum and Maximum to be the Same for All Sparklines 
Click on Column in the Type section of the Design tab.
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Close the Sparklines for Housing Centers workbook
Hierarchy Charts

Open Clients Served in 2016 workbook
Select some or all of the Community areas, neighborhoods, and the data.  
You must also select the column headings
Click on Insert, and choose the Hierarchy Charts from the Charts section.
Choose a Treemap
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Expand the Treemap so that you can easily see the individual blocks.
Explore the different designs
Add a chart title.
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Click on Change Chart Type
Click on Sunburst
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Close the workbook 
Mapping Data
 
Note for student: For this one, if you are not using my sample data sets, you should have a data set already downloaded.  I used the Chicago 311 Graffiti Requests dataset.  
It needs to have a column that connotes time (such as creation date) and location columns (such as Latitude and Longitudes)
 
Open the data set.
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Formatted - Excel 
Normal 
Check Cell 
Neutral 
Linked Cell 
Calculation 
Note 
Conditional Format as 
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Light 
Medium 
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Input 
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Dark 
New Table Style... 
New PivotTable Style... 
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- ]
 
This is a good place to try filters and sort options, like:
· Filtering multiple values
· Searching in the filter search box for values to filter
· Sorting by various criteria
· Etc. 
 
On the left, click in the Table Name box and replace Table1 with Graffiti (or whatever your data set is)
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Removal.xlsx - Excel 
Draw 
Page Layout 
Table Name 
Table 1 
•3 Resize Table 
Creation Date— Status 
FormuLæ 
nsert 
Slicer 
Properties 
Open in Browser 
Ref resh 
Unlink 
Zble Data 
Power Pivot 
HeaderRo..v 
I Row 
Banded Rows 
Team 
First Column 
Last Column 
nded Columns 
Style Options 
Tell me what you want to do 
Filter Button 
Summarize with PivotTable 
Remove Duplicates 
Convert to Range 
Export 
Zble Styles 
2746 W 50TH ST 
Completion Date— Service Request Numbe— Type of Service Reques— What Type of Surface is the Graffiti on — Where is the Graffiti locate* Street Address— ZIP Code— X Coordinate' Y Coordinate— Ward 
Police Distric— Community Area— SSA 
Latitude. Longitude. 
3 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 completed 
3/3/2016 16-01292850 
3/3/2016 16-01290692 
3/3/2016 16-01293583 
3/3/2016 16-01290517 
3/3/2016 16-01290723 
3/3/2016 16-01290510 
3/3/2016 16-01290515 
3/3/2016 16-01287321 
3/3/2016 16-01290677 
3/3/2016 16-01290543 
3/3/2016 16-01290534 
3/3/2016 16-01290525 
3/3/2016 16-01290547 
Graffiti Remova I 
Graffiti Remova I 
Graffiti Removal 
Graffiti Remova I 
Graffiti Removal 
Graffiti Remova I 
Graffiti Removal 
Graffiti Remova I 
Graffiti Removal 
Graffiti Remova I 
Graffiti Removal 
Graffiti Remova I 
Graffiti Remova I 
Metal- Painted 
Brick - unpainted 
Other / unknown Surface 
Metal - unpainted 
Brick - Painted 
Brick - Painted 
Brick - unpainted 
Wood - unpainted 
Brick - Painted 
Brick - Painted 
Metal - Painted 
Metal 
unpainted 
Garbage Cart 
Front 
Mail Box 
847 W BELMONT 
4401 W DIVISION 
5819 W FULLERTC 
1640 W 34TH ST 
5306 S PULASKI R 
2155 W 21ST PL 
2059 W 19TH ST 
2751 W BLOOMI,' 
1132 N MONITOF 
1016 W CULLERT( 
1165 W 18TH ST 
2100 W 19TH ST 
1636 W 34TH ST 
60651 
60639 
60632 
60608 
60647 
60651 
1169936.596 
1146814.312 
1137104.706 
1165855.68 
1150602.188 
1162330.344 
1162942.02 
1157652.986 
1137151.089 
169815.28 
168890.38 
1162672.82 
1165874.98 
1921450.184 
1907631.165 
1915356.767 
1882192.302 
1869112.07 
1889714.362 
1890732.481 
1911864.17 
1906949.595 
1890583.17 
1891562.497 
1890726.081 
1882192.702 
17 41.93985 
41.9024 
41.92378 
41.83243 
41.79659 
41.85292 
41.85569 
41.9138 
41.90122 
41.85537 
41.85785 
41.85592 
41.83243 
-87.651105 
-87.736264 
-87.771732 
-87.667232 
-87.723404 
-87.680488 
-87.678275 
-87.696717 
-87.771842 
-87.652191 
-87.655761 
-87.678512 
-87.667075 ]
Click 3D Map from the Insert tab
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Layers
In the Location box of the Layer options, choose +Add Field, and add Latitude and Longitude
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Latitude 
Longitude 
Police District 
Service Request Number 
SSA 
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Street Address 
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Add Layer 
Layer 1 
Location 
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Add Field 
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Add Field 
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Where it says "select one", choose latitude and longitude respectively.  If there are other fields that automatically came up in your location box, you can delete them by clicking on the X on the right.
Under Height, click + Add Field and choose Service Request Number.  It will default to Count . 
Under Category, click + Add Field and choose Where is the graffiti located.
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Click on the pencil and rename the layer to "Graffiti by Location"
Zoom in using the mouse wheel or using the + and - buttons
Tilt up and down using the arrows
Generally explore the map with the audience
Click on the Layer Options and reduce the thickness of the column to something around 50% (you can see it change in real time so you will know what makes sense for your visualization).
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On the toolbar, click on Map Labels.  This will go to Bing Maps and pull in the labels and put them on your map.  It is important to do this for viewers who may not know your city as well as you do.
 
Scenes
In the Layer Pane, choose Time and + Add Field.  Choose creation date.  If there is a lot of data, this may take a bit.  You will see the status bar on the bottom left say "Processing…"
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 Note the Media Strip
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If you click the "play" button, you will see this data grow over time.  
Right click on the time box on the upper left and change the format to show just days, or months depending on your data set. 
Next click on Scene Options and experiment with the various transition effects.  
Click on the Play Tour button from the toolbar.
 
Click Add Layer to the Layer pane and give this new layer a name
Hide the first layer by clicking on the eye so that you can focus on this new layer
Use a heat map for this layer
Assign the location to Zip Code (or, if your dataset does not have Zip, use some other geography larger in scope than lat/long) and map it to Postal Code
Choose Service Request Number (Count) for the Value
Choose Creation Date for the time
Experiment with Layer Options, showing the impact directly on the map
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Create a scene that shows the heat map alone by Hiding Graffiti by Location and give the scene a meaningful name
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Create a second scene by clicking on the New Scene button at the toolbar and chose to make a copy of the first
Change this scene so that it hides the Heat Map and shows the Requests by Location
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If you like, create a third scene with the two together.
 
Tours
Click Play the tour
Click create video
If you have music you can use, click Use Soundtrack and add it
If you decide to actually go ahead and make the movie, choose a low res option so that it doesn't take a long time
Transforming data
 
Open Address.xlsx or your own dataset that contains addresses
 
First, make some space by creating 5 columns next to the address.  You can name them Block, Address, Direction, Street, and Suffix.  The "Block" column will contain the block-level address (e.g. the 1600 Block vs. the 1612 Address).  
 
From the Data tab on the toolbar, choose Text to Columns
In this case, we will choose Delimited and next. 
Now we tell Excel what character is the delimiter. Notice that we can preview what the data will look like when we are finished.  
Check "Space" and click Next.
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3825 W 63RD ST 
1351 W ADDISON ST 
2222 ARCHER AVE 
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For destination, either select columns that you want to put the data into with the Wizard collapsed, or simply type in the name of the range.  We want to start breaking things up and placing them starting with Address, so it will look like this:
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Click Finish and it should look like this:
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Click on the function button and then type in plain language what it is you are looking for.  
For example, type Round in the search for function, then Go
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Select ROUNDDOWN.
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Select -2 for two decimal places to the left.
When you are done, the function will look like this: =RoundDown (B1,-2)
Notice that Excel predicted that you would want the entire column this way and executed a Flash Fill.
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If you like, you can delete the address column.
 
Insert a column to the left of block.  Call it Block Address
Put the cursor in the first empty row of Block Address (row 2) 
Start typing in the formula bar =CONCATENATE
Notice that Autocomplete starts suggesting concatenate, and when you double click on it, you get a guide for how to use the function
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The function format is: = CONCATENATE(text, text, text).  
After  the "(", click on the first Block address (F2 in the screenshot).
Note that @Block shows up.  Then type ," " in order to insert a space
Click on Direction (H2) followed by ," ",
Click on Street (I2) followed by ," " ,
Click on Suffix and hit enter
 
The full formula will be =CONCATENATE([@Block]," ",[@Direction]," ",[@Street]," ", [@suffix])
 
Enabling the Add-in
In your spreadsheet, click File, Options, and choose Add-ins. 
If you do not see the Analysis Tool Pack already in the list of add-ins, choose Excel-Add-ins from the Manage drop down in the bottom and hit Go
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You will see a list of available add-ins.  Check Analysis Tool Pack and click OK.
Now, when you click on the Data tab, you will see the Analysis Tool Pack.
 
Histogram
Somewhere in the spreadsheet, enter in separate rows on a column 1, 2, 3, 4, 5, 6.  If you are using my sample spreadsheet, it is already there.
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Now, go to the data tab, and click on Data Analysis Tools.
We will start with a simple histogram.  Click Histogram and the following dialog box will appear:
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Select column A for the range
Select your Bins for the Bin Range (including the label, assuming you have Labels checked)
Make sure you check the Labels checkbox (otherwise it will think your label is non-numeric data)
Keep the New Worksheet Ply as your output option (you can give it a name)
Click ok.  That is all there is to it and it quickly analyzed a million rows and gave you the histogram
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Sampling
 
Choose Data Analysis Tools from the Data tab
Choose Sampling.
Give it the input range (if you are using the die spreadsheet, make sure you check Labels).
Tell it how big your sample size should be in Number of Samples
Tell it where you want it to show the output
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Descriptive Statistics
Choose Data Analysis Tools from the Data tab
Choose Descriptive Statistics.
Give it the input range (if you are using the die spreadsheet, make sure you check Labels).
For this example, have it group the data by column 
Output the data to a New Worksheet Ply and give it a name
Check Summary Statistics
Check Confidence Level for Mean (you can keep it at 95%, which is standard)
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